<rmcreative>

RSS

NetBeans 6.9 Milestone 1

17 февраля 2010

Вышла первая более-менее стабильная версия NetBeans 6.9. Уже есть полный список нововведений, я же сконцентрируюсь на PHP, HTML и CSS.

Поддержка Zend Framework.

Ошибки в дереве проекта.

Проекты Symfony с отличным от стандартного расположением директорий.

— Улучшили использование PhpDoc при дополнении кода. Показываются опциональные параметры. Показывается документация

для встроенных итераторов, исключений и часто используемых расширений.

Настраиваемый форматтер кода.

— Рефакторинг CSS: поддержка rename (поиск идёт также по HTML и другим файлам), find usages.

— Дополнение id и классов в HTML и CSS.

Пробуем

Комментарии RSS

  1. №2304
    steexx
    steexx 17.02.2010, 18:40:05

    Вчера только везде обновился с 6.8beta на 6.8... Закон подлости! :)

  2. №2305
    alex.baumgertner
    alex.baumgertner 17.02.2010, 20:09:45

    — Настраиваемый форматтер кода.

    — Рефакторинг CSS: поддержка rename (поиск идёт также по HTML и другим файлам), find usages.

    — Дополнение id и классов в HTML и CSS.

    ура-ура-ура!!!

  3. №2306
    AmdY
    AmdY 18.02.2010, 2:34:08

    если бы ещё ccs хаки и фишки браузеров поддерживались, а то слетает css bilder

  4. №2307
    Ingvar
    Ingvar 18.02.2010, 11:26:11

    Класс! Вот как раз эта фича "Проекты Symfony с отличным от стандартного расположением директорий." мне мешала полностью воспользоваться новыми возможностями.

    Отличный редактор.

  5. №2356
    rustem
    rustem 27.02.2010, 20:00:15

    Добрый вечер

    а чем он отличается от простого 6.8?

    если на их сайт заходить то только 6.8 версия есть, по вашей ссылке6.9м :)

  6. №2363
    Sam
    Sam 03.03.2010, 1:17:54

    6.9 пока ещё не очень стабильна, но есть некоторые новые возможности.

  7. №2475
    webpavilion
    webpavilion 24.04.2010, 19:20:28

    подскажите как smarty к 6.9b прикрутить?

  8. №2476
    Sam
    Sam 25.04.2010, 11:51:00
  9. №2643
    Алексей
    Алексей 16.06.2010, 9:54:28

    А как установить плагин для друпала? При установке 6.9 ругается так:

    Некоторым плагинам необходимо чтобы был установлен плагин Библиотека Редактора (Editor Library).

    Требуется плагин Библиотека Редактора (Editor Library) версии >= 1.29.1.8.2 (версия выпуска 1), но был найден плагин версии 2.10.1.10.2 (с версией выпуска отличной от 1). Затронут следующий плагин:       Drupal Module

    В 6.7 и 6.8 ставился нормально

  10. №2645
    Sam
    Sam 16.06.2010, 13:29:17

    Наверное, плагин пока несовместим с новой версией.

  11. http://hollyit.net/node/1

  12. №4044
    dizel
    dizel 06.03.2011, 22:18:10

    А как в NetBeans настроить автоматический ввод параметров описания функций?

  13. №5098
    Михаил
    Михаил 03.08.2011, 14:25:51

    Немного не в тему, но больше спросить неукого. Есть ли плагин для netbeans, который бы добавлял окно просмотра страницы рядом с окном кода? Как в dreamweaver...

  14. №5106
    Sam
    Sam 03.08.2011, 17:34:44

    Не встречал.

  1. Почта опубликована не будет.

  2. Можно использовать синтаксис Markdown или HTML.

  3. Введите ответ в поле. Щёлкните, чтобы получить другую задачу.